Get in touch
Back
Maintenance

Scheduled maintenance

Completed 1 Feb at 02:16am CET.

Main Server Webserver The Moonlit Den - Proxy
Completed

Maintenance completed

Posted 1 Feb at 02:16am CET.
Updated

We apologize for the long delay but all our services should now be fully functional again. Thank you for your extended patience on this ride with us.

Posted 1 Feb at 02:07am CET.
Started

We are upgrading our networking equipment. Please stand by as we migrate.

Posted 30 Jan at 06:30pm CET.