Get in touch
Back
Maintenance

Minecraft upgrade to 1.18.1

Completed 24 Jan at 10:00am CET.

The Moonlit Den - Proxy
Completed

Maintenance completed

Posted 24 Jan at 10:00am CET.
Started

We are upgrading our main network to 1.18.1 which will result in downtime as we take the necessary steps to shift versions.

Posted 24 Jan at 09:00am CET.